• Creator
    Topic
  • #16975

    Timothy Hall
    Spectator
    Been thanked: 0 times

    When using Jetpack’s “Tiled Galleries” feature, thumbnails are linking to the Attachment Page instead of to the images themselves.

    I first posted this here.. and Alex suggested I start a new thread (here).

    Alex said..

    Could you search for the following code inside Justified Image Grid, and let me know what comes after?

    add_filter( ‘post_gallery’

    Thanks!

    @mendocinotim As Alex mentioned, could you please start your own thread, as per the Forum Welcome?
    http://wordpress.org/support/plugin/jetpack#postform

    Thank you!

    I spooked around in the Jetpack Plugin Directory until I found the following file..
    /wp-content/plugins/jetpack/modules/carousel/jetpack-carousel.php
    ..Where I found (starting on line 31) the following code:

    Is that what you wanted me to find?

Viewing 12 replies - 1 through 12 (of 12 total)
Replies
  • Timothy Hall
    Spectator
    Post count: 9
    Been thanked: 0 times
    #16982 |

    BTW – I’m not sure I was clear about the issue, which is in two parts.

    Part 1: Galleries created by hand, or when posted via email (with Jetpack’s Tiled Galleries enabled) do not behave like a gallery set – in other words, each image requires a click on it’s own thumbnail in the resulting generated tiled mosaic to view it; next/previous does not apply ‘although it is supposed to.

    Part 2: Galleries, when posted by email (with Jetpack’s Tiled Galleries enabled) connect to the Attachment Page ‘rather then to the image file.

    I just wanted to be sure you understand the bad behaviors here as I see them.

    Roman
    Keymaster
    Post count: 2543
    Been thanked: 29 times
    #16988 |

    does this work with default wp theme?

    Timothy Hall
    Spectator
    Post count: 9
    Been thanked: 0 times
    #16989 |

    Nope – I tried it with the WP 2013 theme and my results are pretty much the same.
    After I switched to 2013 ‘I posted using Postie with several images.

    One thing I noticed after observing these test results (when I later switched back to my normal “Alora” theme)..
    The resulting Tiled Gallery post – when I click one of the front-end gallery thumbnails – pops up the following error message..

    Roman
    Keymaster
    Post count: 2543
    Been thanked: 29 times
    #16990 |

    try more themes…if the result is same, then the bug is not in our theme

    Timothy Hall
    Spectator
    Post count: 9
    Been thanked: 0 times
    #16991 |

    I also tried it with the 2015 theme – same thing.
    I’ll try asking the Jetpack people instead.

    Roman
    Keymaster
    Post count: 2543
    Been thanked: 29 times
    #16994 |

    yes, it will be better as we don’t provide support of 3rd plugins

    Timothy Hall
    Spectator
    Post count: 9
    Been thanked: 0 times
    #16995 |

    Something new I just discovered.
    To begin, I decided to disable Jetpack’s Tiled Gallery option, and instead installed another plugin “Tiled Galleries Carousel Without Jetpack” ‘that is described by the author as..

    Transform your standard image galleries into an immersive full-screen experience without Jetpack.This plugin is made from Jetpack Modules. You can get the tiled galleries with Full screen carousel with out connecting to wordpress.com account.

    I am running this with Jetpack enabled, but the Tiled Galleries Jetpack feature disabled.
    I am getting another result that suggests there is a theme-related component to this issue.

    Here’s a 3-min screen capture movie that shows what I did and what I am now getting.

    In brief..
    Using “Tiled Galleries Carousel Without Jetpack” and the 2013 theme, I created a gallery by hand – it worked.
    Then I switched back to the Alora theme, and without changing the page ‘I reloaded the preview, and the images in the gallery were no longer linked as a single gallery (as before) – in other words, each masonary gallery thumb on the front end would link only to that clicked image ‘with no next/prev behavior.

    Wouldn’t this be a them-related issue?

    Roman
    Keymaster
    Post count: 2543
    Been thanked: 29 times
    #17006 |

    you have probably enabled the built in Lightbox feature of alora, Appearance -> Theme Options -> Advanced -> Disable Lightbox

    Timothy Hall
    Spectator
    Post count: 9
    Been thanked: 0 times
    #17054 |

    I finally solved this issue.
    I had to contact the Jetpack people – and they (Jeremy) pointed out that the Alora theme uses a “PrettyPhoto” plugin to handle galleries. So I did a search and found one called “Royal PrettyPhoto” – which I then installed; and this fixed the issues I was having with posting a gallery via email or by hand.

    I also disabled Alora’s own Lightbox and then reenabled it ‘testing for differences; and there is not any apparent difference on the front end.

    In any case – after several days fighting with this issue..
    Now the images are properly tied together as a gallery.

    I suggest you look into this.

    Here’s a link to the final forum exchange (for Jetpack) – where the final solution was uncovered.

    Roman
    Keymaster
    Post count: 2543
    Been thanked: 29 times
    #17057 |

    well, I am assuming that disabling the Light box feature solved the issue 😕

    Timothy Hall
    Spectator
    Post count: 9
    Been thanked: 0 times
    #17058 |

    Actually no.
    I have the built-in (Alora theme) lightbox enabled; and still, it’s working properly now.
    The only thing I had to do to get everything working was to add the “Royal PrettyPhoto” plugin.

    My understanding is that Alora uses this invisibly; and the built-in version was not linking the images as a gallery set; but by manually adding the “Royal PrettyPhoto” plugin and enabling it, this (for some reason) does correct this issue.

    You might want to have a look at this requirement, since I’m sure you never intended this.

    Roman
    Keymaster
    Post count: 2543
    Been thanked: 29 times
    #17059 |

    that’s pretty weird

Viewing 12 replies - 1 through 12 (of 12 total)
You must be logged in to reply to this topic.