• Creator
    Topic
  • #26364

    Rafal Budniok
    Spectator
    Been thanked: 0 times

    Hello.
    We are having a problem with yours theme. The excerpt is set to yes and length to 55. But it dosen’t works at all.
    Home site still shows full length of the article. We are using a static page . With Theme4Press Shortcodes.

Viewing 12 replies - 1 through 12 (of 12 total)
Replies
  • Denzel Chia
    Moderator
    Post count: 3230
    Been thanked: 129 times
    #26377 |

    Hi,

    Are you referring to the recent post shortcode?

    The variable excerpt_length is not working, Please change to excerpt_words
    For example,

    If this is not the shortcode you are using. Please post your shortcode.

    Thank you

    Thank you.

    Rafal Budniok
    Spectator
    Post count: 7
    Been thanked: 0 times
    #26424 |

    I’m using this shortcode:

    With yours shortcode is no difference: look at http://new.fhupartner.pl/. Posts still are shown at full size.

    Denzel Chia
    Moderator
    Post count: 3230
    Been thanked: 129 times
    #26427 |

    Hi,

    Please see my previous reply.
    I ask you to try changing excerpt_length="55" to excerpt_words="55"

    The shortcode that you pasted is still using excerpt_length

    Thank you

    Rafal Budniok
    Spectator
    Post count: 7
    Been thanked: 0 times
    #26431 |

    Changed to excerpt_words="55" Still shows full lenght.

    Denzel Chia
    Moderator
    Post count: 3230
    Been thanked: 129 times
    #26434 |

    Are you using a cache plugin?
    Please clear cache content.

    If it still does not work.
    Provide WordPress login access in private reply.
    I take a look for you.

    Thank you

    Rafal Budniok
    Spectator
    Post count: 7
    Been thanked: 0 times
    #26435 |

    Cache cleared .I sent PM

    Rafal Budniok
    Spectator
    Post count: 7
    Been thanked: 0 times
    #26436 |
    This reply has been marked as private.
    Denzel Chia
    Moderator
    Post count: 3230
    Been thanked: 129 times
    #26437 |

    Hi,

    I cannot find the reason why it does not work on your website.
    I had copied your shortcode and use it on my test site.
    I am able to get the auto-generated excerpt to work properly on my test site.

    As a workaround, Please use the crafted excerpt setting ( Zajawka setting )
    I tried adding the sentence “This is a crafted excerpt” into your latest post and it worked.

    At the moment please use this workaround.

    Thank you.

    Rafal Budniok
    Spectator
    Post count: 7
    Been thanked: 0 times
    #26438 |

    Ok.
    Another problem. Button class=”read-more btn t4p-button-default dosen’t translate correctly . On the main page at the begining shows translations correct (wiecej…) but after that below on the same page shows without translations (Read More).

    Denzel Chia
    Moderator
    Post count: 3230
    Been thanked: 129 times
    #26449 |

    Hi,

    There are many read more buttons in the shortcodes, you need to translate them all.
    The blog shortcode is in theme4press core plugin.

    You need to use poedit
    https://poedit.net/

    You may need to update the strings.

    If you are unable to translate it, you can go to T4p-core/shortcodes/class-blog.php line 1001 to make the edit.

    Thank you

    Rafal Budniok
    Spectator
    Post count: 7
    Been thanked: 0 times
    #26464 |

    Ok thanks. Works fine .

    Denzel Chia
    Moderator
    Post count: 3230
    Been thanked: 129 times
    #26470 |

    You are welcome!

    Thank you.

Viewing 12 replies - 1 through 12 (of 12 total)
You must be logged in to reply to this topic.