• Creator
    Topic
  • #19954

    Jochen
    Spectator
    Been thanked: 0 times

    Hello,
    I’ve translated the alora theme using PoEdit (except everything in the admin folder). When I place the de_DE.po / .mo-files in the alora\languages directory, most of the site is localized.

    On pages using the blog-shortcode the translation is ignored (everything is still in English), while on single-post or category pages (not using the shortcode) everything works as expected.

    Any hints, what might be wrong?

    I’m using alora 2.7 (t4p-core 1.3.0) on WP 4.3.

    Jochen

Viewing 3 replies - 1 through 3 (of 3 total)
Replies
  • Denzel Chia
    Moderator
    Post count: 3225
    Been thanked: 129 times
    #19996 |

    Hi,

    The blog shortcode gets the post that you written, if you written them as English, it will be in English, if you written your content in German, it will be in German.
    Only Theme strings are translatable.

    Please post your website url to your page with blog shortcode. I need to see it in order to understand your issue.

    Thanks!

    Jochen
    Spectator
    Post count: 5
    Been thanked: 0 times
    #19999 |

    Hi,
    I meant the theme strings. The Site is currently in development and not yet available on the global internet.

    Actually I found a workaround by changing the translation calls in the file t4p-core/shortcodes/class-blog.php from __(”, ‘t4p-framework’) to __(”, ‘alora’).

    Then the translation from the theme is used.

    Thanks for your help!

    Jochen

    Denzel Chia
    Moderator
    Post count: 3225
    Been thanked: 129 times
    #20000 |

    Hi,

    Thank you very much for this information.

    Regards,
    Denzel

Viewing 3 replies - 1 through 3 (of 3 total)
You must be logged in to reply to this topic.