• Creator
    Topic
  • #8563

    Helena Guevara
    Spectator
    Been thanked: 0 times

    Hello, I am new to wordpress and looking in the forum I couldn’t find a thread adressing this issue. My website is: feldenkrais-online.es.
    The first two menu items on the menu are drop down, in most cases when I try to access the items in the drop down menu they flicker and I need several seconds to be able to select- this gives the website an unprofessional look. I tried with firefox, chrome and safari and it is more or less them same flickering. Any help?

Viewing 13 replies - 1 through 13 (of 13 total)
Replies
  • Nicem SpA
    Spectator
    Post count: 28
    Been thanked: 0 times
    #10302 |

    I have the same issue, but worse. I have 2nd and 3rd level drop-down menu also: when you try to select an item from the drop-down menus, it often disappear like you move the cursor out of them. It’s very annoying, you must try and retry to open the desired page.
    I invite you to try it on test2.nicem.it going on “Prodotti” and going down to 2nd e 3rd level menù.
    I disabled the “rollin effect” but the issue persist. This is a bug I expected to be solved in one theme update. Surely it must be fixed before our website goes on-line (now is under construction on test space).
    thank you

    Nicem SpA
    Spectator
    Post count: 28
    Been thanked: 0 times
    #10311 |

    In this video (grabbing browser window) you can see the issue. As you can see, the drop-down menu disappear. Mouse buttons was NOT clicked.

    Nicem SpA
    Spectator
    Post count: 28
    Been thanked: 0 times
    #10335 |

    Any answer?

    Roman
    Keymaster
    Post count: 2538
    Been thanked: 29 times
    #10366 |

    I would suggest two options, you can completely disable the effect by putting this in the Custom CSS field because your menu items are too long:

    Code:
    .link-effect a span {
    -webkit-transition: none;
    -moz-transition: none;
    transition: none;
    }

    .link-effect a span::before {
    -webkit-transform: none;
    -moz-transform: none;
    transform: none;
    }

    or just change the hover text weight to normal by putting:

    Code:
    .link-effect a span:before
    Nicem SpA
    Spectator
    Post count: 28
    Been thanked: 0 times
    #12574 |

    As I wrote on 1 August, “I disabled the “rollin effect” but the issue persist.” so I’m using the first option yet from weeks.
    I tried to insert in the custom css this code
    .link-effect a span:before
    but nothing happens, the links in the drop-down menu still became bold when selected. I think the code is incorrect. Can you fix it?
    Thank you

    Roman
    Keymaster
    Post count: 2538
    Been thanked: 29 times
    #12591 |

    sorry, just updated the forum and the code is not correct anymore, try this one:

    .link-effect a span::before {font-weight:normal!important;}

    Nicem SpA
    Spectator
    Post count: 28
    Been thanked: 0 times
    #12606 |

    Thank you Roman, now the code works. Menu behaviour now is better but it still suddenly disappear when mouse cursor get in the thin space between menù colums, from 1th and 2nd level or 2nd and 3rd. See the image to understand. I think there is a margin to delete in CSS to get menù columns closer, one against other, avoiding to create empty space between them.
    Last question: it’s possible to avoid pop-up text label on menù links? I think here it’s redundant and annoying.

    thank you!

    Roman
    Keymaster
    Post count: 2538
    Been thanked: 29 times
    #12620 |

    try this code:

    .link-effect a span:before,ul.nav-menu li.current-menu-item a, ul.nav-menu li.current-menu-ancestor a {font-weight:normal!important;}

    Nicem SpA
    Spectator
    Post count: 28
    Been thanked: 0 times
    #12631 |

    Hi Roman, I’ve inserted the new code (instead of .link-effect a span::before {font-weight:normal!important;}) but nothing has changed: the thin space between menù colums is still there and so the text labels do. The menù still often disappear when mouse cursor moves over it. Thank for support.

    Roman
    Keymaster
    Post count: 2538
    Been thanked: 29 times
    #12637 |

    try this code if it helps:

    Nicem SpA
    Spectator
    Post count: 28
    Been thanked: 0 times
    #12659 |

    Hi Roman, I added your code but often menu still disappears. I would suggest to try to get menù columns closer, one against other, avoiding to create empty space between them.

    It’s would great if we can avoid pop-up text label when mouse goes on menù links too.
    Thank you!

    Roman
    Keymaster
    Post count: 2538
    Been thanked: 29 times
    #12686 |

    sorry I provided the solutions which I know now…the menu is coded as it is

    Nicem SpA
    Spectator
    Post count: 28
    Been thanked: 0 times
    #12779 |

    At least, it is possible to remove the pop-up text labels from menù links? Thank you

Viewing 13 replies - 1 through 13 (of 13 total)
You must be logged in to reply to this topic.