• Creator
    Topic
  • #8540

    Sam
    Spectator
    Been thanked: 2 times

    Hi,

    Help!

    I am building a bilingual website with English and Chinese. However, when i choose “Recent Posts” short code and define “Number of Excerpt Words” to 35, it works well for English posts but no good for Chinese one. All Chinese words in the post is shown in the screen which is not desirable.

    Any idea how to accommodate Chinese words for Excerpt function?

    Thanks,
    Sam

Viewing 2 replies - 1 through 2 (of 2 total)
Replies
  • Sam
    Spectator
    Post count: 12
    Been thanked: 2 times
    #10212 |

    Hi,

    Suppose Alora didn’t support Chinese words excerpt, and i have downloaded several plugins which works well for many Chinese sites, such as below:

    http://wordpress.org/plugins/wp-utf8-excerpt/installation/

    The developer says if the plugin doesn’t work, look in your theme directory, edit the index.php file (content.php file in twenty ten/eleven theme) by changing:

    <?php the_content(); ?>
    to

    <?php
    if (is_single() or is_page()) {
    the_content();
    } else {
    the_excerpt();
    }
    ?>

    In Alora, i didn’t find <?php the_content(); ?> under /public_html/wp-content/themes/alora/index.php, however i found this sentence in page.php and portfolio-three-column.php that i am using for my blog.

    After i replace the code as developer suggests in in page.php and portfolio-three-column.php, thing won’t change.

    Do you know how to disable Alora’s excerpt tag setting and use wordpress default one or work as plugin expected?

    Much appreciated!

    Roman
    Keymaster
    Post count: 2538
    Been thanked: 29 times
    #10215 |

    the the_content() function is also available in the index.php file. sorry but we dont test our themes with 3rd party plugins so we cannot guarantee they will work or not

Viewing 2 replies - 1 through 2 (of 2 total)
You must be logged in to reply to this topic.