• Creator
    Topic
  • #24640

    Carrie Norwood
    Spectator
    Been thanked: 0 times

    I installed the template about a week ago and I am really struggling to get some of the finer details hammered out. Any help would be appreciated.

    1) I want the fa icons here (using shortcode) : http://distanceparent.org/get-involved/
    To look like the ones in the content boxes here : http://distanceparent.org/
    How do I change the shortcode or css to do that?

    2) I have two sidebars.. one on the left and one on the right. I want to adjust the sidebar width for BOTH sidebars.
    This : #secondary { max-width: 200px !important;}
    adjusts the sidebar on the right.

    This : #primary { width: 55%;}
    adjusts the middle content section.

    How do I adjust the second sidebar width?

    3) If I edit a page : The default settings are : Template = Default Template, Sidebar = None, Sidebar Position = no sidebar. Using those default settings, ever page has two sidebars, one on the right, one on the left, which is the blog default. No matter how I change the sidebar or the Sidebar position, it puts the same sidebar on the left of the post. How do I tell it which sidebar to display on a page and where?

    As a side note : my site does not pass W3 Validation : https://validator.w3.org/nu/?doc=http%3A%2F%2Fdistanceparent.org%2F Most, if not all of those errors are from the theme’s code. I will need to manually clean my templates up. It would be nice if the theme could be made to validate!

    Thanks,
    Carrie

Viewing 12 replies - 1 through 12 (of 12 total)
Replies
  • Carrie Norwood
    Spectator
    Post count: 8
    Been thanked: 0 times
    #24641 |

    I found ONE page sidebar option that works. If I select two sidebars on the right, it does what I would expect and puts both sidebars to the right of the page. Here is an example :

    Legal Resources

    Denzel Chia
    Moderator
    Post count: 2841
    Been thanked: 91 times
    #24685 |

    Hi,

    Regarding question 1.

    Use the following in Theme Options -> Custom CSS

    Regarding question 2.

    Second sidebar id is #secondary-2

    Regarding question 3.

    Your homepage will follow the default layout in your Theme Options -> Layout.

    As for your posts or pages, you will have to edit the page, scroll down and use the page options -> Sidebar Position

    Regarding question 4.

    You can follow the discussion here.
    https://wordpress.org/support/topic/div-classmask-error?replies=12
    Or wait for fix in next version update.

    I will report this W3 Validation Issue to my employer.

    Thank you

    Carrie Norwood
    Spectator
    Post count: 8
    Been thanked: 0 times
    #24746 |

    Questions 1&2 are fixed! Thank you!

    #3 : “As for your posts or pages, you will have to edit the page, scroll down and use the page options -> Sidebar Position” – this issue is, those options at the bottom of the page editor aren’t doing what they say they should do. Here are 4 example pages… two are working and two are not.

    These two are working as expected :
    A. This page : http://distanceparent.org/books-and-products/
    has sidebar=none and sidebar position = two on the left and it has two sidebars on the left – this is what I would expect. This one is working.

    B. This page : http://distanceparent.org/community/
    has sidebar=none and sidebar position = two on the right and it has two sidebars on the right – this is what I would expect. This one is working.

    These two are NOT working as expected :
    C: This page : http://distanceparent.org/resource-kit/legal-resources-court/federal-law/
    has sidebar=”none” and sidebar position = “none” and it has a sidebar on the left and the right, which is the site default.

    D : This page : http://distanceparent.org/about/
    has sidebar=none and sidebar position = one on the right and it has a sidebar on the left and the right, which is the site default. I would expect to mark one sidebar on the right and hve it have only one sidebar on the right.

    For both of the two that are not working, I’ve tried setting sidebar= sidebar1 and sidebar2 with no change.

    Thanks,
    Carrie

    Denzel Chia
    Moderator
    Post count: 2841
    Been thanked: 91 times
    #24783 |

    Hi,

    For Sidebar Position = none, you need to set it to Full Width = yes
    For any other layout, you need to set Full Width = No

    If you still required help.

    Please provide WordPress login access in private reply.
    I will login and try to set it up for you.

    Thank you

    Carrie Norwood
    Spectator
    Post count: 8
    Been thanked: 0 times
    #24829 |

    Hi,

    I tried setting full width = yes on the federal law page (item C) and it blew the template out… the content section moved below the left sidebar and the right sidebar below that.

    C: This page : http://distanceparent.org/resource-kit/legal-resources-court/federal-law/
    has sidebar=”none” and sidebar position = “none”. It still has both sidebars, whether fullpage=yes or no. If Fullpage=yes, the template gets blown out. I would expect it to have no sidebar, based upon the settings.

    D : This page : http://distanceparent.org/about/
    has sidebar=none and sidebar position = one on the right and it has a sidebar on the left and the right, which is the site default. I would expect to mark one sidebar on the right and have it have only one sidebar on the right.

    If you could address these two and tell me how it was addressed, I can fix the rest. What level of access do you need and what email address do I use for the account?

    Denzel Chia
    Moderator
    Post count: 2841
    Been thanked: 91 times
    #24864 |

    Hi,

    I will need administrator login access.

    You can use a fake email address.
    Use any username, such as t4press_support and pass me the username.
    Click on show password button and copy to me the password before you click on Add New User button.

    Reply to me with the login details in private reply.

    Thank you

    Carrie Norwood
    Spectator
    Post count: 8
    Been thanked: 0 times
    #24885 |
    This reply has been marked as private.
    Denzel Chia
    Moderator
    Post count: 2841
    Been thanked: 91 times
    #24891 |

    Hi,

    You are right. There is a bug.
    I had added the following custom css in your Theme Options -> Custom CSS as a temporary fix.

    I will inform my employer about this bug.

    Thank you

    Carrie Norwood
    Spectator
    Post count: 8
    Been thanked: 0 times
    #24910 |

    Both of these pages are now set to sidebar position = two on the right and they only display one sidebar, even if I change it to both sidebars on the right.

    About

    Federal Law

    Carrie Norwood
    Spectator
    Post count: 8
    Been thanked: 0 times
    #24911 |

    I have also noticed that the pages are not respecting the header widget option. If ‘Enable Header Widgets’ is set to ‘no’ on a page, the page is still displaying the header widget. Both pages above show this as well.

    Denzel Chia
    Moderator
    Post count: 2841
    Been thanked: 91 times
    #24947 |

    I am putting the sidebar bug on record here, so that my employer can replicate it.

    1) In Theme Options -> General -> Layout
    Select 2 sidebars.

    2) Add a page and set right sidebar as per following screenshot.
    After publishing, the left sidebar will still be showing and the right sidebar gets pushed down.

    3) Add a page and set no sidebar and full width as per following screenshot.
    After publishing, the left sidebar appears on top of full width content.

    There could be other bugs with layout. Therefore, it’s advisable to check all possible combinations.

    Thank you.

    Denzel Chia
    Moderator
    Post count: 2841
    Been thanked: 91 times
    #24954 |

    Hi Carrie,

    For header widgets, In Theme Options -> Header Widgets -> Header Widgets Placement
    Please set it to Select Per Post / Page.

    For your information.
    Please insert any link to this forum using the link button in the editor.
    If not, nothing will show up in your reply.

    Thank you.

Viewing 12 replies - 1 through 12 (of 12 total)
You must be logged in to reply to this topic.