• Creator
    Topic
  • #15647

    keith white
    Spectator

    I have been using Evolve plus and I like it very much Although…. today I went on my site and all I got was
    Fatal error: Cannot redeclare class Contact_Info_Widget in/wp-content/themes/evolve-plus/library/functions/widgets/contact_info.php on line 117

    I accessed my site through my server and changed to the free version and it it working fine… I deleted Evolve plus and loaded it again however it just crashes my site again with the same error?????

Viewing 10 replies - 1 through 10 (of 10 total)
Replies
  • Carl Grasso
    Spectator
    Post count: 1
    #15648 |

    I’m having the same issue. I am fairly confident it is the Jetpack plugin. Disabling it causes the website to work again, and redownloading and installing Jetpack kills it again. There was an update to Jetpack today and it appears that that update is the culprit.

    keith white
    Spectator
    Post count: 3
    #15649 |

    I shut off my plugins through my server, wile on the free evolve theme I than deleted the theme and its child than activated it again…. created a new child and everything seems to be fine…. I do have the jetpack update and all is working….(for now)

    keith white
    Spectator
    Post count: 3
    #15650 |

    just tried loading evolve plus on another site …..just to see what happens…. and yup it crashed…. deleted jetpack and sure enough it works fine….. the thing that confuses me right now is….. how is it working now on my other site that is running the new jetpack update?………..beats me!

    Our World Enterprises
    Spectator
    Post count: 57
    #15652 |

    I just updated JetPack and ended up with the same issue…. 🙁

    Fatal error: Cannot redeclare class Contact_Info_Widget in /home/WEBSITENAME/public_html/ReseckExcavation.com/wp-content/themes/alora/widgets/contact_info.php on line 117

    Problem is, I am pretty fresh in WordPress and am not sure how to fix it?

    Can I back out the update? I had Jetpack to start with and it was fine. Its the update that caused it….

    Our World Enterprises
    Spectator
    Post count: 57
    #15653 |

    Oh, I forgot to mention, I am running Alora… Not Evolve.

    Our World Enterprises
    Spectator
    Post count: 57
    #15662 |

    I was able to fix this by replacing the Contact_Info_Widget in the three references in the named file to alora_Contact_Info_widget

    keith white
    Spectator
    Post count: 3
    #15663 |

    log into your server (where you host your site) go to your “file manager” look for “wp-content” open the file… look for the file named “themes” right click on it and change the name to “themes.hold” than you will be able to log back onto your sites dashboard…. than delete jet pack…. go back to your “themes.hold” file and change the name back to “themes” this will get you back on line
    if you want the jet pack find the previous version on line and save it as a zip to your computer load it through plugins/add plugins/upload plugin…. but to keep it from updating you will than have to go to “edit” on the plugin and change where it says version 3.? to 3.4 to keep it from updating…… but like I said before it is now running on one of my sites…. and I still don’t know why lol but it will not run on my other sites…. using different theme so … not a problem…
    hope this helps!

    Our World Enterprises
    Spectator
    Post count: 57
    #15664 |

    Thanks @keith White, however I was able to fix this by replacing the Contact_Info_Widget in the three references in the named file to alora_Contact_Info_widget

    Roman
    Keymaster
    Post count: 2712
    #15677 |

    will be fixed

    Michelle Marin-Chavez
    Spectator
    Post count: 1
    #15749 |

    I tried what Keith suggested and now I cant even log into my site at all and Im really new to WordPress…how do I change the names in the referenced files? Update…I tried suggestion again and it worked this time. Thank you Keith for the advice…I can live without Jetpack I think.

Viewing 10 replies - 1 through 10 (of 10 total)

The topic ‘Fatal error: Cannot redeclare class Contact_Info_Widget in’ is closed to new replies.