Topic Resolution: Resolved
Viewing 10 replies - 1 through 10 (of 10 total)
Replies
  • Roman
    Keymaster
    Post count: 2538
    Been thanked: 29 times
    #15244 |

    you have enabled widgets area but there are no widgets…disable them in the Theme Options -> Footer

    Graham Newell
    Spectator
    Post count: 118
    Been thanked: 0 times
    #15245 |

    Thanks, thanks, and thanks again. =)

    I think the only other thing I need to do is setup Recaptcha, could you let me know if I have done it properly.

    G.

    http://vipermetal.wpengine.com/contact-2/

    Roman
    Keymaster
    Post count: 2538
    Been thanked: 29 times
    #15247 |

    it’s not enabled/installed yet. download the plugin first

    Greg Vaughan
    Spectator
    Post count: 27
    Been thanked: 0 times
    #20082 |

    Help, I too want to decrease the height of my footer and can’t figure out how. In my case, there is a widget enabled in the footer. Here is the site url: http://test.bbblack.com

    Denzel Chia
    Moderator
    Post count: 2871
    Been thanked: 94 times
    #20102 |

    Hi,

    In your Theme Options-> Custom CSS

    Try removing your footer padding.

    or set a height to overwrite the default value.

    Change the values accordingly.

    I suggest you fill up your content area with some blog posts first, before doing these adjustments.

    Thanks!

    Greg Vaughan
    Spectator
    Post count: 27
    Been thanked: 0 times
    #20124 |

    Denzel, thanks for the suggestions, but neither had any affect at all on the footer. Changing the footer padding or height settings resulted in no change. The space at the bottom of the home pages also appears to be either a padding or margin issue with the content buttons. Together, the content buttons and footer create way too much space at the bottom. Any further suggestions?

    Denzel Chia
    Moderator
    Post count: 2871
    Been thanked: 94 times
    #20129 |

    Hi,

    Sorry, I have to highlight again, I suggest you finish designing your site first, before doing these adjustments. Bring up the footer like this will cause problem to other pages when you fill up your content, the footer may go up over your content.

    In your WordPress admin -> Theme Options -> Custom CSS

    Save your changes.

    After that, clear your browser cache before revisiting your site.

    Screenshot of the result. http://share.pho.to/9fiSl/us/original

    Thanks!

    Greg Vaughan
    Spectator
    Post count: 27
    Been thanked: 0 times
    #20149 |

    Denzel, thanks so much. Your code does reduce the height of the footer, finally.

    In terms of the footer working properly on all site pages, I’m confused. This site will have Blog, Portfolio, and Testimonial pages that will continue to accumulate content, pushing further and further down the pages. Won’t the footer, with the proper reduced height, simply float below whatever content is on these pages? If not, how do I prevent the content and the footer overlapping?

    http://test.bbblack.com

    Greg Vaughan
    Spectator
    Post count: 27
    Been thanked: 0 times
    #20151 |

    I went ahead and inserted your suggested code in the custom CSS window,just to see how the other pages look with at this point in the site’s development. Here are problems that your code is causing now:

    • The footer on most pages is way too close to the content – no apparent padding or margin on the footer top, or the content bottom.

    • The entire content window, including the footer, now scroll up past the sticky image in the left sidebar on pages with that feature.

    How do I get a footer, with a specified height, that stays a fixed distance from any content above, and neither the content or footer scroll beyond sticky images in left sidebars?

    Denzel Chia
    Moderator
    Post count: 2871
    Been thanked: 94 times
    #20183 |

    Hi,

    If I am not wrong, you used a third party plugin text widget “widget_black_studio_tinymce” for your footer note.

    This is not the recommended way. You should add your footer note via Theme Options -> Footer -> Custom footer instead of using a widget. The theme structure is not designed to work this way, not to mention the widget also has it’s own padding, that’s why there is too much empty space.

    Using custom css to “forcefully” bring up the footer note will result in overlapping other contents on other pages.
    Sorry, I think this is not the correct way, we should remove it, and start all over again.

    Please kindly remove the custom css and remove the text widget. Please kindly use Theme Options -> Footer -> Custom footer to enter your footer note.

    And in Theme Options -> Footer -> Number of widget cols in footer
    Please set this option to “none”, if you are not using any footer widgets, this will reduce empty space.

    After doing the above recommendations, we will see if we still require any further custom css.

    Sorry for causing any inconveniences.

    Thanks!
    Denzel

Viewing 10 replies - 1 through 10 (of 10 total)
You must be logged in to reply to this topic.