• Creator
    Topic
  • #18171

    steven wilson
    Spectator
    Been thanked: 0 times

    in mobile Chrome (and desktop Firefox with window narrowed) the responsive mobile menu icon is broken along with its menu top image. See screen grab:

    https://goo.gl/photos/jReDR3xeyjKYGuoz9

    I’ve fixed fa on all desktop browsers but mobile seems to be broken.

Viewing 3 replies - 1 through 3 (of 3 total)
Replies
  • Denzel Chia
    Moderator
    Post count: 2849
    Been thanked: 91 times
    #18185 |

    Hi,

    Works properly for me.
    Please see a screenshot from my iPhone. http://prntscr.com/7fmpbz
    Not by narrowing desktop window.

    Seems like your server is still giving you issue on font-awesome fonts.
    This is a screenshot from my desktop. http://prntscr.com/7fmqkn
    No font-awesome icons.
    See firebug, font-awesome loading from CDN or within Evolve theme are all blocked by CORS

    I am no server expert and does not know how to resolve this CORS issue, but looking at your previous forum thread,
    https://theme4press.com/support/topic/all-fontawesome-icons-showing-broken-symbol/
    I think you are well verse in server setting. So perhaps this article is able to help you. http://benjaminhorn.io/code/setting-cors-cross-origin-resource-sharing-on-apache-with-correct-response-headers-allowing-everything-through/

    Base on the fact that font-awesome fonts on our demo site is showing up properly, and the CORS errors seen in my firebug console when visiting your site, I would like to highlight that this is not a theme issue but your own server setup issue.

    Thanks!
    Denzel

    steven wilson
    Spectator
    Post count: 22
    Been thanked: 0 times
    #18214 |

    Thanks, it was indeed still a CORS problem. I fixed it by adding

    to my .htaccess file in the root of the subdirectory where the wordpress files live. I had modified this file previously but must have needed to tweak it a bit. For the benefit of someone finding this post with the same problem, there is an .htaccess file in the root of the server as well, which I did not edit.

    Interestingly, it seems that Firefox is following the correct procedure in not allowing CORS fonts to be loaded, and the fact that they were showing in webkit-based browsers is an error on the part of the devs of those browsers. Here’s hoping all of this sticks as browsers are updated to comply with regulations.

    Now my only remaining problem is that the mobile menu ‘bar’ (which starts with the three line menu icon) is blank. Can it say ‘menu’ or something like that?

    Roman
    Keymaster
    Post count: 2538
    Been thanked: 29 times
    #18226 |

    sure try this Appearance -> Theme Options -> Custom CSS

Viewing 3 replies - 1 through 3 (of 3 total)
You must be logged in to reply to this topic.