• Creator
    Topic
  • #36912

    Mark Leder
    Participant

    Presently using Free version of Evolve v394 (purchased premium theme but have not installed)

    Constant log errors, as follows:

    2018/08/08 05:37:57 [error] 4380#4380: *13082 FastCGI sent in stderr: “PHP message: PHP Notice: register_sidebar_widget is deprecated since version 2.8.0! Use wp_register_sidebar_widget() instead. in /var/www/html/_rosalind-sedacca/childcentereddivorce.com/wwwroot/wp-includes/functions.php on line 3853

    PHP message: PHP Notice: register_widget_control is deprecated since version 2.8.0! Use wp_register_widget_control() instead. in /var/www/html/_rosalind-sedacca/childcentereddivorce.com/wwwroot/wp-includes/functions.php on line 3853″ while reading response header from upstream, client: 172.68.58.33, server: childcentereddivorce.com, request: “GET /?wordfence_lh=1&hid=1FB3AEF678602C64CE09F787AF0861BD&r=0.45519681543191104 HTTP/1.1”, upstream: “fastcgi://unix:/var/run/php-fpm/php-fpm.sock:”, host: “www.childcentereddivorce.com”

    I’ve rebuilt the child theme to eliminate the possibility of problems there. Cloudflare is turned off, nginx cache has been cleared repeatedly.

    Been going on for quite some time, using latest WP 4.9.8
    Centos 7.2, Nginx latest stable build. Lightly loaded fast server.

Viewing 10 replies - 1 through 10 (of 16 total)
Replies
  • Roman
    Keymaster
    Post count: 2712
    #36913 |

    Hello Mark, thanks for your purchase. May I know which functionality of the premium version made you decide to purchase it? I can prepare a version with the fixed bug.

    Mark Leder
    Participant
    Post count: 7
    #36914 |

    >> May I know which functionality of the premium version made you decide to purchase it?
    Didn’t really look at the functionality, needed support to fix a long running client problem.

    Also, one more constant error message:
    PHP message: PHP Notice: Constant WP_USE_THEMES already defined in /var/www/html/_rosalind-sedacca/childcentereddivorce.com/wwwroot/index.php on line 14″, client: 162.158.75.134, server: childcentereddivorce.com, request: “GET / HTTP/1.1”, host: “www.childcentereddivorce.com”

    Mark Leder
    Participant
    Post count: 7
    #36918 |

    >> I can prepare a version with the fixed bug.
    Do you have an estimate as to when this might be ready?

    Roman
    Keymaster
    Post count: 2712
    #36920 |

    Hello Mark,

    yes, just got in the testing stage and making sure I fix as many bugs as possible. Maybe tomorrow I could upload an upcomming version 😉

    Roman
    Keymaster
    Post count: 2712
    Mark Leder
    Participant
    Post count: 7
    #36933 |

    This doesn’t solve my immediate problem that is impacting server performance.

    Roman
    Keymaster
    Post count: 2712
    #36934 |

    were the above errors resolved? Can you provide more details please?

    Roman
    Keymaster
    Post count: 2712
    #36935 |

    these errors are not related to the evolve parent theme itself:

    if you are using a child theme, probably there are defined those functions which are outdated. I made sure those functions I updated in the both evolve versions

    Mark Leder
    Participant
    Post count: 7
    #36937 |

    Nope, errors are still there, even with a brand new, empty child theme. in one day I get a gig of errors on this site.

    Roman
    Keymaster
    Post count: 2712
    #36938 |

    it’s weird because none of both, evolve theme or Theme4Press Core don’t use those functions. Would be possible to get login details to the website in Private reply so I may have a look?

Viewing 10 replies - 1 through 10 (of 16 total)
You must be logged in to reply to this topic.