• Creator
    Topic
  • #26846

    Armin Ogasa
    Spectator
    Been thanked: 0 times

    After installing the new Theme, i get this error:

    Warning: file_exists(): open_basedir restriction in effect. File(/customers/c/d/d/digitaldistribution.de/httpd.www/wp-content/themes/evolve-plus/library/admin/redux-extensions/extensions/headerdefault/headerdefault.js/extension_headerdefault.js.php) is not within the allowed path(s): (/customers/c/d/d/digitaldistribution.de/httpd.www:/customers/c/d/d/digitaldistribution.de/httpd.private:/customers/c/d/d/digitaldistribution.de/tmp:/customers/digitaldistribution.de/digitaldistribution.de:/var/www/diagnostics:/usr/share/php) in /customers/c/d/d/digitaldistribution.de/httpd.www/wp-content/plugins/redux-framework/ReduxCore/inc/class.redux_api.php on line 543 Warning: Cannot modify header information – headers already sent by (output started at /customers/c/d/d/digitaldistribution.de/httpd.www/wp-content/plugins/redux-framework/ReduxCore/inc/class.redux_api.php:543) in /customers/c/d/d/digitaldistribution.de/httpd.www/wp-includes/option.php on line 823 Warning: Cannot modify header information – headers already sent by (output started at /customers/c/d/d/digitaldistribution.de/httpd.www/wp-content/plugins/redux-framework/ReduxCore/inc/class.redux_api.php:543) in /customers/c/d/d/digitaldistribution.de/httpd.www/wp-includes

    I get this in any case, i deactivated and even deleted all plugins, the old themes folder and updated wordpress, then installed the theme and i always get this error.
    I dont want to loose all my content, because, if i use a clean install, it works. Can you tell me where this error comes from?

    Best

Viewing 7 replies - 1 through 7 (of 7 total)
Replies
  • Denzel Chia
    Moderator
    Post count: 3225
    Been thanked: 129 times
    #26865 |

    Hi,

    Please refer to the following for explanation.
    http://stackoverflow.com/questions/1846882/open-basedir-restriction-in-effect-file-is-not-within-the-allowed-paths

    Maybe your hosting company changed a setting.
    Please contact them for help.

    Or try updating reduxframework plugin to latest version.

    Thank you.

    Armin Ogasa
    Spectator
    Post count: 17
    Been thanked: 0 times
    #27002 |

    No they didnt. Yes i updated.
    I asked them for help, the only thing that they could do was disabling the php error messages.

    As i was saying, this DOESNT happen with clean installs.

    When i delete everything on the webserver, clear the database and then install a fresh version of wordpress and then the theme, this doesnt happen.

    This only happens when i update. So, of course, this cant be a fault from the hoster.

    How can i get to this open_basedir thing?
    Or is there a way there i can get all my content from the old install into a new install?

    Armin Ogasa
    Spectator
    Post count: 17
    Been thanked: 0 times
    #27003 |

    I know because of the deactivation of the php error messages, this doesnt mean the errors are gone.

    Somehow this needs to work, the Site is taking soooo much time to load since the update and those errors…

    Denzel Chia
    Moderator
    Post count: 3225
    Been thanked: 129 times
    #27023 |

    Hi,

    I had set WP_DEBUG to true.
    I don’t see those warnings on my test site.

    If you like, I can produce a screen-cast for you to see.
    No warnings, No slow down in speed…

    I don’t understand why your web hosting company cannot assist you in “removing” the restriction on open_basedir which is a server setting.

    Your web hosting company does not own their servers? Maybe they are resellers of hosting account?…

    By the way, that is a warning, not error.
    If it’s an error, your website will not load.

    Thank you.

    Armin Ogasa
    Spectator
    Post count: 17
    Been thanked: 0 times
    #27035 |

    I dont understand that, too!

    Is there a way to access this by myself? Is this in php my admin or where can i find this setting? What exactly needs to be removed in this setting?

    Best

    Armin Ogasa
    Spectator
    Post count: 17
    Been thanked: 0 times
    #27039 |

    But there is still one thing i need to know…
    Why does this happen when i Update the theme? This doesnt happen when i make a clean install!
    Is there something that needs to be deleted?

    Denzel Chia
    Moderator
    Post count: 3225
    Been thanked: 129 times
    #27099 |

    Hi,

    My employer seems to have a solution for this issue.
    https://theme4press.com/support/topic/installation-problems/

    Please re-download Theme from your account and re-install on your site.

    Thank you.

Viewing 7 replies - 1 through 7 (of 7 total)
You must be logged in to reply to this topic.