Topic Resolution: Resolved
  • Creator
    Topic
  • #18180

    Johnny Good
    Spectator
    Been thanked: 0 times

    Hi,

    With previous version I just did few translations on the home page but for some reason after update they’re back to English.
    Translated “Written by” using https://wordpress.org/plugins/codestyling-localization/ and made sure
    /wp-content/themes/evolve-plus/languages/en_EN.po
    has this
    #: archive.php:90
    #: archive.php:214
    #: author.php:73
    #: author.php:197
    #: content-blog.php:64
    #: content-blog.php:217
    #: index.php:70
    #: index.php:196
    #: search.php:70
    #: search.php:230
    #: single.php:74
    #@ evolve
    msgid “Written by”
    msgstr “Poslato od”

    Is it because I’m using child theme and need something in there?

Viewing 8 replies - 1 through 8 (of 8 total)
Replies
  • Denzel Chia
    Moderator
    Post count: 2858
    Been thanked: 92 times
    #18183 |

    Hi,

    There has been a lot of changes in code for that update. Previously there was only index.php, now it was separated into many templates. So the English po file and po files are not having the same ‘location” for the words now.

    Please kindly use that codestyling-localization plugin to regenerate the en_EN.po and en_EN.mo file and redo your translation.

    Very sorry for causing these inconveniences.

    By the way, this codestyling-localization plugin is a really good one, but does not know why it’s not available in WordPress plugins repository now.

    Thanks!
    Denzel

    Johnny Good
    Spectator
    Post count: 90
    Been thanked: 0 times
    #18228 |

    Hi,

    Yes, the plugin is great and it was good before.

    After every translation I was re-generating en_EN.mo file but I do not see where to re-generate en_EN.po file?

    View post on imgur.com

    View post on imgur.com

    Lukasz
    Spectator
    Post count: 43
    Been thanked: 0 times
    #18231 |

    On the second screen, which you attached; you have button “Rescan” – use it.

    Johnny Good
    Spectator
    Post count: 90
    Been thanked: 0 times
    #18239 |

    Forgot to mention but I do that every time and it does not make any difference.
    Re-scan, Edit, translate Written By, generate mo-file still same.

    Johnny Good
    Spectator
    Post count: 90
    Been thanked: 0 times
    #18271 |

    Anyone?

    Denzel Chia
    Moderator
    Post count: 2858
    Been thanked: 92 times
    #18303 |

    Hi,

    I tried out the translation and it’s working properly for me.
    Please see screenshot, this is before translation. http://prntscr.com/7hxtak

    This is after I switch to Chinese language. http://prntscr.com/7hxtt1

    This shows that our language file still work for the “Written by” string.

    Thanks!
    Denzel

    Denzel Chia
    Moderator
    Post count: 2858
    Been thanked: 92 times
    #18305 |

    Hi,

    Forgot to mention, you need to make sure that the language folder has the language files that you need.
    Not the en_US.po or en_US.mo, that’s for English. For example, you need the zh_CN.po and zh_CN.mo for chinese language.

    And also you need to switch your site language to the language that you want.
    It’s located in WordPress admin -> Settings -> General at the end of the page.

    Hope this helps.

    Thanks!
    Denzel

    Johnny Good
    Spectator
    Post count: 90
    Been thanked: 0 times
    #18503 |

    Hi,

    Finally got it to work.
    Adding my language as you suggested did not wok in my case.
    What worked is deleting English lang from here http://prntscr.com/7l1unz and adding English lang again.
    Re-scan English, Edit, translate Written By, generate mo-file and voila it works!
    Just wanted to reply back in case someone runs into same issue.
    Again, thanks for your help!

Viewing 8 replies - 1 through 8 (of 8 total)
You must be logged in to reply to this topic.