Viewing 8 replies - 1 through 8 (of 8 total)
Replies
  • Alok Maheshwari
    Spectator
    Post count: 303
    Been thanked: 0 times
    #13725 |

    Can you please clarify which image is the correct one and which one is being shared incorrectly.

    Maurizio Delladio
    Spectator
    Post count: 5
    Been thanked: 0 times
    #13729 |

    I attach screenshot of debugging facebook. The corrected image is highlighted. The problem actually arises almost always and with most of the post. It is usually associated with an image present in a widget flexslider outside the post.

    https://www.dropbox.com/s/0irpkyy3qx0uwr9/screenshot.png?dl=0

    Alok Maheshwari
    Spectator
    Post count: 303
    Been thanked: 0 times
    #13730 |

    That plugin doesn’t seem to work. Try a plugin like https://wordpress.org/plugins/wp-facebook-open-graph-protocol/

    Maurizio Delladio
    Spectator
    Post count: 5
    Been thanked: 0 times
    #13731 |

    I have now added a new image inside the post. But if I try to share not see it and if you do I debug the image is not even visible from the associated.

    https://www.dropbox.com/s/5rih9n0kqi8c4qj/Screenshot%202014-12-08%2001.30.05.png?dl=0

    https://www.dropbox.com/s/p7ynudbq1kr8137/Screenshot%202014-12-08%2001.30.53.png?dl=0

    Maurizio Delladio
    Spectator
    Post count: 5
    Been thanked: 0 times
    #13732 |

    I removed the plugin Facebook Image Fix and installed Facebook Open Graph Protocol, but the problem remains, and all associated images are wrong. I tried to share with four posts and the problem persists

    Alok Maheshwari
    Spectator
    Post count: 303
    Been thanked: 0 times
    #13735 |

    When trying to post it on facebook, it is correctly showing following 3 images which are included in the og:image tag as can be seen in the source code of the page. Not sure why the debugger is selecting the http://www.delladio.it/wordpress/wp-content/uploads/2013/12/054.jpg image.

    <meta property=”og:image” content=”http://www.delladio.it/wordpress/wp-content/uploads/2014/12/mdelladio.jpeg”/>
    <meta property=”og:image” content=”http://www.delladio.it/wordpress/wp-content/uploads/2010/07/berlinguer-300×213.jpg”/>
    <meta property=”og:image” content=”http://www.delladio.it/wordpress/wp-content/uploads/2014/12/39707-80891.jpg”/>

    Maurizio Delladio
    Spectator
    Post count: 5
    Been thanked: 0 times
    #13737 |

    thanks for asking but the problem remains. These are the screens of another post. In the post is not inserted an image associated which is present only in a slaider below.
    https://www.dropbox.com/s/gk25f6bdq2u4rgk/post.png?dl=0
    https://www.dropbox.com/s/1vp1q09nye7nsl0/Screenshot%202014-12-08%2012.31.04.png?dl=0
    https://www.dropbox.com/s/6zxto19tgs0n3os/debug.png?dl=0
    Sigh!

    Alok Maheshwari
    Spectator
    Post count: 303
    Been thanked: 0 times
    #13738 |

    The problem is with fb only. It maybe caching the site content. You can verify it by first trying to post the url in facebook, which if cached, will show you older images. Then in object debugger, click on “Fetch new scrape information” which should try to get the latest code and tell you that

    “og:image was not defined, could not be downloaded or was not big enough. Please define a chosen image using the og:image metatag, and use an image that’s at least 200x200px and is accessible from Facebook. Image ‘http://www.delladio.it/wordpress/wp-content/uploads/2014/12/P4250860.jpg’ will be used instead.”

    Now it will show the 3 images link and despite them having required width, it will tell you “When shared, this is what will be included” with a different image. But when you try to post this url again, you can see that now it will allow us to select 1 of the 3 images for which the og:image tag was found.

Viewing 8 replies - 1 through 8 (of 8 total)
You must be logged in to reply to this topic.