• Creator
    Topic
  • #29768

    Tim Riedel
    Participant
    Been thanked: 1 time

    I followed all steps in the custom fonts documentation:

    Custom Fonts

    But it seems the theme ignores this custom fonts. I cant see anything of my font also in the developer tools.
    The font is RubrikLight.

    If you need I can send you the URL of my page in a private message.

    Thanks for help 😉

Viewing 11 replies - 1 through 11 (of 11 total)
Replies
  • Daniel Jones
    Moderator
    Post count: 241
    Been thanked: 19 times
    #29769 |

    Hi TIm,

    Thank you for getting in touch.

    Hmm, were the custom files uploaded correctly (.woff, .tff, .svg, .eot)? Yes, kindly share the URL to you website so we can have a closer look at this. Also, please note that custom Font will only display on the headings and navigational menus.

    Hope to hear from you soon.

    Tim Riedel
    Participant
    Post count: 11
    Been thanked: 1 time
    #29770 |

    Hey Thanks for the quick answer 😉

    Yes the files are correctly uploaded.
    But the theme still use the standard font of ‘Open Sans’, Arial, Helvetica, sans-serif;
    Also if I change the standard font like the google font to “nothing”.
    The onliest solution for me now is to use custom css, to define which elements should use my custom font.
    But normally I think it should work automatically..!?

    I will send you the URL by the next message..

    Tim Riedel
    Participant
    Post count: 11
    Been thanked: 1 time
    #29771 |

    Hey Mr. Jones, sorry but we have to wait until tomorrow, because the external URL isnt configured yet.
    I will send you as soon as I have it 😉

    Daniel Jones
    Moderator
    Post count: 241
    Been thanked: 19 times
    #29772 |

    Hi Tim,

    Yes, custom CSS can also come in handy here. I will wait for the URL tomorrow. In the meantime, you can try and upload another font to rule out if its an issue with the font itself. 🙂

    Let me know.

    Tim Riedel
    Participant
    Post count: 11
    Been thanked: 1 time
    #29785 |
    This reply has been marked as private.
    Daniel Jones
    Moderator
    Post count: 241
    Been thanked: 19 times
    #29787 |
    This reply has been marked as private.
    Tim Riedel
    Participant
    Post count: 11
    Been thanked: 1 time
    #29788 |

    I tried your idea to change the font-files to another. I choose a font where I’m sure that it is working, because this font is actually used at an other website. But unfortunately it doesn’t fix the problem.
    I realize that always if I upload my custom font the browser (chrome) use “Open Sans”, Arial, Helvetica, sans-serif even if I delete all settings in Google-fonts and standard-fonts.

    Tim Riedel
    Participant
    Post count: 11
    Been thanked: 1 time
    #29789 |
    This reply has been marked as private.
    Tim Riedel
    Participant
    Post count: 11
    Been thanked: 1 time
    #29791 |

    I also realized that the font is correctly integrated, because if I change the font-family value to rubrik-light I can see changes.

    Daniel Jones
    Moderator
    Post count: 241
    Been thanked: 19 times
    #29797 |

    Hi Tim,

    Thanks for reaching out to us again.

    Kindly could you confirm if the issue has been resolved so that we may go ahead to close this ticket. 🙂

    Looking forward to your reply.

    Tim Riedel
    Participant
    Post count: 11
    Been thanked: 1 time
    #29823 |

    Hi Daniel,

    I resolved it now with custom css, by define font-family: rubrik-light; that works fine 😉

    Thanks for your help.

Viewing 11 replies - 1 through 11 (of 11 total)
You must be logged in to reply to this topic.