• Open
  • Phil Herwaldt
    Participant
    September 23, 2019 at 8:24 pm #44185

    I am having a really weird issue with the testimonials shortcode. Every time I update the page, the code for the tesitmonials changes. It does not seem to matter whether I am editing the testimonial code or any other code on the page. Whenever I update this page, I have to do it twice. The first update breaks the testimonials, the second update fixes it.

    When the testimonial shortcode is broken, the webpage will display the first quote and then flash a second quote and then it disappears altogether. The only way to display the testimonials again is the refresh the webpage.

    Here is a screenshot of the code. The first (red) is the “broken” code, the second (green) is the code that works.
    http://prnt.sc/p9yjkc

    You can view the working code about half-way down the main page at: https://todaysnative.org/

    Evgeny
    Keymaster
    Posts: 202
    September 23, 2019 at 11:35 pm #44187

    I’m gonna have to ask you a few questions.
    1. WordPress version?
    2. Evolve+ version?
    3. PHP version?
    4. Are you using Gutenberg or Classic Editor?
    5. Component Shortcodes plugin version?
    Thanks.

    Phil Herwaldt
    Participant
    Posts: 11
    September 26, 2019 at 11:47 pm #44203

    1. WordPress version? – 5.2.3
    2. Evolve+ version? – 2.9.7
    3. PHP version? – 7.2.7
    4. Are you using Gutenberg or Classic Editor? – Gutenberg – I am using a “classic” block though in order to use the theme4press shortcodes.
    5. Component Shortcodes plugin version? – 1.0.0

    Phil Herwaldt
    Participant
    Posts: 11
    September 26, 2019 at 11:54 pm #44204

    I just updated the Component Shortcodes version to 1.0.1 and it appears to be having the same issue.

    Evgeny
    Keymaster
    Posts: 202
    September 27, 2019 at 6:35 pm #44208

    Any particular reason why you do not update to the latest version of the theme? We are at 2.9.8.6 now. A lot of bugs and problems solved along the way.

    Phil Herwaldt
    Participant
    Posts: 11
    October 7, 2019 at 9:16 pm #44241

    Ok, I had been dragging my feet on updating to the most recent version because it looked a little complicated, but I went ahead and did it on all my websites. I am very pleased with the results. Several unrelated issues under the “site health” area were resolved, I am very pleased.

    However, this particular “Testimonial Shortcode” issue is still not resolved with the update. If I update the main page once, the shortcode displays one testimonial, then when it cycles to the second, all the text immediately disappears. When I update the page again, it works normal again! If you visit our site, it is working right now. If you would like me to intentionally leave it in the not working condition so you can see it, let me know.

    Evgeny
    Keymaster
    Posts: 202
    October 8, 2019 at 11:47 am #44247

    Glad to hear, that updating was a good experience. API key makes it a whole lot easier. The Testimonial shortcode problem is probably some kind of compatibility issue with one of your plugins. This is usually what it is… You can even find out which one if you switch the plugins one by one and test the functionality of the shortcode.