Topic Resolution: Resolved
  • Closed
  • Phil Herwaldt
    Participant
    June 23, 2020 at 8:09 pm #44925

    I run the Evolve theme on all three of my websites. I also use the Theme API key for updating and have been for some time now. Two of my website have been updating fine and are currently at 2.9.9.5. The third is stuck at 2.9.9.3. It tells me everything is up to date and there are no new updates available (I have double-checked the key multiple times). I tried updating the theme via the cPanel, following carefully the instructions on your website for updating the theme. I renamed the “old” theme, then uploaded the zip file for 2.9.9.5 and extracted it. It seems to work fine at first, but then a few weird things happen. When I am in the “customize” panel, everything looks off. The theme API will not show, all the icons on the panel are goofy and some don’t even show up at all. The website itself is all jumbled up. When I go back to the “theme” page in the wordpress admin area, the icon for the new Evolve theme doesn’t show up. I am absolutely baffled and have tried the procedure several times and get the same result. WordPress and all other plugins are up to date.

    Phil Herwaldt
    Participant
    Posts: 13
    June 23, 2020 at 8:56 pm #44927

    Ok, well after a fourth try it appears that the update has worked. I don’t know exactly why? I have my site to default to the WordPress 2020 theme if anything happens to the Evolve theme. When I renamed the old version in cPanel, I went back and refreshed the theme page in the wordpress dashboard. I noticed the old 2.9.9.3 version was deactivated and a weird “phantom” version of Evolve was active. I activated TwentyTwenty theme instead and then proceeded to upload the 2.9.9.5 zip file, extracted it, and then refreshed the theme page back in the wordpress admin panel. When I activated 2.9.9.5, everything went as it should have to start with. I am assuming this time the update worked because I activated a different theme during the update process. I know this is not required according to your directions. I have seen some fluky things with 2.9.9.3 (such as the theme refusing the recognize it needed to be updated) so maybe there was another quirk with this somewhere? Anyway, it appears like it is finally working as it is supposed to. Thanks!

    Evgeny
    Keymaster
    Posts: 481
    June 23, 2020 at 10:48 pm #44929

    Hi. I’m sorry you’ve run into trouble. The step you’re describing usually isn’t required, that’s why it is not in the instructions. Anyway, now you should be able to update through the API without any problem. If you need anything else, please let us know.